Configuration Guide: EIGRP

From: IP Routing: EIGRP Configuration Guide, Cisco IOS Release 15M&T


EIGRP Autonomous System Configuration

  • The router eigrp as-number command creates an EIGRP configuration called the EIGRP autonomous system configuration, or EIGRP classic mode.
  • The EIGRP autonomous system configuration creates an EIGRP routing instance that can be used for exchanging routing information.


EIGRP Named Configuration

  • The router eigrp name command creates an EIGRP configuration referred to as the EIGRP named configuration or EIGRP named mode.
  • An EIGRP named configuration does not create an EIGRP routing instance by itself; it is a base configuration that is required to define address-family configurations that are used for routing.


Goodbye Message

  • The goodbye message is a feature designed to improve EIGRP network convergence. The goodbye message is broadcast when an EIGRP routing process is shut down to inform adjacent peers about an impending topology change.
  • The following message is displayed by devices that run a supported release when a goodbye message is received: *Apr 26 13:48:42.523: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.1.1(Ethernet0/0) is down: Interface Goodbye received
  • A Cisco device that runs a software release that does not support the goodbye message can misinterpret the message as a K-value mismatch and display the following error message: *Apr 26 13:48:41.811: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.1.1(Ethernet0/0) is down: K-value mismatch


Metric Weights

  • The metric weights command adjusts the default behavior of EIGRP routing and metric computations.
  • By default, the EIGRP composite cost metric is a 32-bit quantity that is the sum of segment delays and the lowest segment bandwidth (scaled and inverted) for a given route.
  • However, with the EIGRP Wide Metrics feature, the EIGRP composite cost metric is scaled to include 64-bit metric calculations for EIGRP named mode configurations.


Mismatched K Values

  • EIGRP K values are the metrics that EIGRP uses to calculate routes. 
  • Mismatched K values can prevent neighbor relationships from being established and can negatively impact network convergence.
  • The following error message is displayed when the K values are mismatched: *Apr 26 13:48:41.811: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.1.1 (Ethernet0/0) is down: K-value mismatch
  • The following are two scenarios where the above error message can be displayed:
    1. Two devices are connected on the same link and configured to establish a neighbor relationship. However, each device is configured with different K values.
    2. One of two peers has transmitted a “peer-termination” message (a message that is broadcast when an EIGRP routing process is shut down), and the receiving device does not support this message. The receiving device will interpret this message as a K-value mismatch.


Routing Metric Offset Lists

  • An offset list is a mechanism for increasing incoming and outgoing metrics to routes learned via EIGRP. 
  • Optionally, you can limit the offset list with either an access list or an interface. 
  • NOTE: Offset lists are available only in IPv4 configurations. IPv6 configurations do not support offset lists.


EIGRP Cost Metrics

  • Bandwidth - The minimum bandwidth of the route, in kilobits per second. It can be 0 or any positive integer. The bandwidth for the formula is scaled and inverted by the following formula: (107/minimum bandwidth (Bw) in kilobits per second)
  • Delay - Route delay, in tens of microseconds.
  • Reliability - The likelihood of successful packet transmission, expressed as a number between 0 and 255, where 255 means 100 percent reliability and 0 means no reliability.
  • Load - The effective load of the route, expressed as a number from 0 to 255 (255 is 100 percent loading).
  • MTU - The minimum MTU size of the route, in bytes. It can be 0 or any positive integer. (Not part of the metric calculation.)
  • The default K values:
    • K1 - 1
    • K2 - 0
    • K3 - 1
    • K4 - 0
    • K5 - 0
  • The default formula of 256*(Bw + Delay), where Bw = 10^7/minimum Bw in kilobits per second and Delay = sum of delays on the path, is the EIGRP metric.
  • For example, look at a link whose bandwidth to a particular destination is 128 k and the delay is 84,000 microseconds.
  • Metric = 256*(10^7/128 + 84000/10) = 256*86525 = 22150400

Route Summarization

  • Automatic summarization is performed when two or more network router configuration or address family configuration commands are configured for an EIGRP process.
  • This feature is enabled by default. (Seriously??)
  • Route summarization works in conjunction with the ip summary-address eigrp command available in interface configuration mode for autonomous system configurations and with the summary-address (EIGRP) command for named configurations.
  • You can configure a summary aggregate address for a specified interface. If there are specific routes in the routing table, EIGRP will advertise the summary address of the interface with a metric equal to the minimum metric of the specific routes.


Floating Summary Routes

  • A floating summary route is created by applying a default route and an administrative distance at the interface level or address family interface level.
  • Example: The default summary route is applied to serial interface 0/1 on Device-B with the following autonomous system configuration:

Device-B(config)# interface Serial 0/1
Device-B(config-if)# ip summary-address eigrp 100 0.0.0.0 0.0.0.0

  • The default summary route is applied to serial interface 0/1 on Device-B with the following named configuration:

Device-B(config)# router eigrp AVERY
Device-B(config-router)# address-family ipv4 unicast vrf vrf1 autonomous-system 1
Device-B(config-router-af)# interface serial 0/1
Device-B(config-router-af-interface)# summary-address 192.168.0.0 255.255.0.0 95

  • This configuration also generates a local discard route—a route for 0.0.0.0/0 on the null0 interface with an administrative distance of 5—on Device-B. When this route is created, it overrides the EIGRP-learned default route. Device-B will no longer be able to reach destinations that it would normally reach through the 0.0.0.0/0 route.
  • This problem is resolved by applying a floating summary route to the interface on Device-B that connects to Device-C.
  • The floating summary route is applied by configuring an administrative distance for the default summary route on the interface of Device-B with the following statement for an autonomous system configuration:

Device-B(config-if)# ip summary-address eigrp 100 0.0.0.0 0.0.0.0 250

  • The floating summary route is applied by configuring an administrative distance for the default summary route on the interface of Device-B with the following statement for a named configuration:

Device-B(config)# router eigrp AVERY
Device-B(config-router)# address-family ipv4 unicast vrf vrf1 autonomous-system 1
Device-B(config-router-af)# af-interface serial0/1
Device-B(config-router-af-interface)# summary-address eigrp 100 0.0.0.0 0.0.0.0 250

  • The administrative distance of 250, applied in the summary-address command, is now assigned to the discard route generated on Device-B. The 0.0.0.0/0, from Device-A, is learned through EIGRP and installed in the local routing table. Routing to Device-C is restored.
  • You should configure the summary address with an administrative distance only on single-homed remote devices or areas that have only one exit point between two segments of the network.
  • If two or more exit points exist (from one segment of the network to another), configuring the floating default route can result in the formation of a black hole route (a route that has quick packet dropping capabilities).


Hello Packets and Hold Time Intervals

  • Routing devices periodically send hello packets to each other to dynamically learn of other devices on their directly attached networks. This information is used to discover neighbors and to learn when neighbors become unreachable or inoperative.
  • By default, hello packets are sent every 5 seconds. The exception is on low-speed, nonbroadcast multiaccess (NBMA) media, where the default hello interval is 60 seconds. Low speed is considered to be a rate of T1 or slower, as specified with the bandwidth interface configuration command.
  • The hold time is advertised in hello packets and indicates to neighbors the length of time they should consider the sender valid. The default hold time is three times the hello interval or 15 seconds. For slow-speed NBMA networks, the default hold time is 180 seconds.


Split Horizon

  • When split horizon is enabled on an interface, update and query packets are not sent to destinations for which this interface is the next hop. Controlling update and query packets in this manner reduces the possibility of routing loops.
  • By default, split horizon is enabled on all interfaces.
  • Split horizon blocks route information from being advertised by a device out of any interface from which that information originated.


EIGRP Dual DMVPN Domain Enhancement

  • EIGRP, by default, sets the local outbound interface as the next-hop value while advertising a network to a peer, even when advertising routes out of the interface on which the routes were learned.
  • This default setting can be disabled by using the no ip next-hop-self command in autonomous system configurations or the no next-hop-self command in named configurations.
  • When the next-hop self command is disabled, EIGRP does not advertise the local outbound interface as the next hop if the route has been learned from the same interface. Instead, the received next-hop value is used to advertise learned routes.


Link Bandwidth Percentage

  • By default, EIGRP packets consume a maximum of 50 percent of the link bandwidth when configured with the bandwidth interface configuration command for autonomous system configurations and with the bandwidth-percent command for named configurations.


How To Configure EIGRP


Enabling EIGRP Autonomous System / Classic EIGRP Configuration


! Configures an EIGRP routing process and enters router configuration mode.
! A maximum of 30 EIGRP routing processes can be configured.
Device(config)# router eigrp 1
! Associates a network with an EIGRP routing process.
Device(config-router)# network 172.16.0.0

Enabling the EIGRP Named Configuration


Configuring the router eigrp virtual-instance-name command creates an EIGRP named configuration. The EIGRP named configuration does not create an EIGRP routing instance by itself. The EIGRP named configuration is the base configuration, which is required to define address family configurations used for routing.

! Configures the EIGRP routing process and enters router configuration mode.
Device(config)# router eigrp AVERY
! Enters address family configuration mode to configure an EIGRP IPv4 routing instance.
! Command syntax: address-family ipv4 [multicast] [unicast] [vrf vrf-name] autonomous-system as-number
Device(config-router)# address-family ipv4 autonomous-system 45000
! Specifies a network for the EIGRP routing process.
Device(config-router-af)# network 172.16.0.0

Configuring Optional EIGRP Parameters in an Autonomous System Configuration


Device(config)# router eigrp 1
! Suppresses EIGRP hello packets and routing updates on interfaces while still including the interface addresses in the topology database.
! Command syntax: passive-interface [default] [interface-type interface-number
Device(config-router)# passive-interface GigabitEthernet0/0/0
! Applies an offset to routing metrics.
! Command syntax: offset-list [access-list-number | access-list-name] {in | out} offset [interface-type interface-number
Device(config-router)# offset-list 21 in 10 GigabitEthernet0/0/1
! Adjusts the EIGRP metric or K value.
! Command syntax: metric weights tos k1 k2 k3 k4 k5
Device(config-router)# metric weights 0 2 0 2 0 0
! Disables automatic summarization. Note: Automatic summarization is enabled by default. 
! This command guide says automatic summarization would enabled by default on IOS 15.3
! The command reference says that the command default behavior was changed to disabled from 12.2(8)T. See: auto-summary (EIGRP)
Device(config-router)# no auto-summary

Configuring Optional EIGRP Parameters in a Named Configuration


Device(config)# router eigrp AVERY
Device(config-router)# address-family ipv4 autonomous-system 45000
Device(config-router-af)# network 172.16.0.0
! Adjusts the EIGRP metric or K value.
! Command syntax: metric weights tos k1 k2 k3 k4 k5 k6
Device(config-router-af)# metric weights 0 2 0 2 0 0 0
! Enters address family interface configuration mode and configures interface-specific EIGRP commands.
Device(config-router-af)# af-interface GigabitEthernet0/0/1
! Suppresses EIGRP hello packets and routing updates on interfaces while still including the interface addresses in the topology database.
Device(config-router-af-interface)# passive-interface GigabitEthernet0/0/0
! Configures the percentage of bandwidth that may be used by an EIGRP address family on an interface.
Device(config-router-af-interface)# bandwidth-percent 75
! Exits address family interface configuration mode.
Device(config-router-af-interface)# exit-af-interface
! Configures an EIGRP process to route IP traffic under the specified topology instance and enters address family topology configuration mode.
Device(config-router-af)# topology base
! Applies an offset to routing metrics.
Device(config-router-af-topology)# offset-list 21 in 10 GigabitEthernet0/2
! Disables automatic summarization. Note: Automatic summarization is enabled by default. (Wrong!)
! See above.
Device(config-router-af-topology)# no auto-summary

Configuring the EIGRP Redistribution Autonomous System Configuration


You must use a default metric to redistribute a protocol into EIGRP, unless you use the redistribute command. Default metrics are supported only when you are redistributing from EIGRP or static routes.

Device(config)# router eigrp 1
! Redistributes routes from one routing domain into another routing domain.
Device(config-router)# redistribute rip
! Allows the use of two administrative distances—internal and external.
Device(config-router)# distance eigrp 80 130
! Sets metrics for EIGRP.
! Command syntax: default-metric bandwidth delay reliability loading mtu 
Device(config-router)# default-metric 1000 100 250 100 1500

Configuring the EIGRP Route Summarization Autonomous System Configuration


Device(config)# router eigrp 101
! Disables automatic summarization of subnet routes into network-level routes
Device(config-router)# no auto-summary

Device(config)# interface Gigabitethernet 1/0/3
! Puts an interface into Layer 3 mode
Device(config-if)# no switchport
! Sets the inherited and received bandwidth values for an interface
Device(config-if)# bandwidth 56
! Configures a summary aggregate address.
! Command syntax: ip summary-address eigrp as-number ip-address mask [admin-distance] [leak-map name]
Device(config-if)# ip summary-address eigrp 100 10.0.0.0 0.0.0.0
! Configures the percentage of bandwidth that may be used by EIGRP on an interface.
! Command syntax: ip bandwidth-percent eigrp as-number percent
Device(config-if)# ip bandwidth-percent eigrp 209 75

You should not use the ip summary-address eigrp summarization command to generate the default route (0.0.0.0) from an interface because this creates an EIGRP summary default route to the null0 interface with an administrative distance of 5. The low administrative distance of this default route can cause this route to displace default routes learned from other neighbors through the routing table. If the default route learned from the neighbors is displaced by the summary default route, or if the summary route is the only default route present, all traffic destined for the default route will not leave the router; instead, traffic will be sent to the null 0 interface, where it is dropped. The recommended way to send only the default route out of a given interface is to use the distribute-list command. You can configure this command to filter all outbound route advertisements sent out from the interface with the exception of the default (0.0.0.0).

Configuring the EIGRP Route Summarization Named Configuration


Device(config)# router eigrp AVERY
Device(config-router)# address-family ipv4 autonomous-system 45000
Device(config-router-af)# af-interface GigabitEthernet0/0/1
! Configures a summary address for EIGRP.
! Command syntax: summary-address ip-address mask [administrative-distance [leak-map leak-map-name]]
Device(config-router-af-interface)# summary-address 192.168.0.0 255.255.0.0
Device(config-router-af-interface)# exit-af-interface
Device(config-router-af)# topology base
! Configures a fixed metric for an EIGRP summary aggregate address.
! Command syntax: summary-metric network-address subnet-mask bandwidth delay reliability load mtu
Device(config-router-af-topology)# summary-metric 192.168.0.0/16 10000 10 255 1 1500

Configuring the EIGRP Event Logging Autonomous System Configuration


Device(config)# router eigrp 101
! Sets the size of the EIGRP event log.
Device(config-router)# eigrp event-log-size 5000010
! Enables logging of EIGRP neighbor adjacency changes. By default, the system logs EIGRP neighbor adjacency changes to help you monitor the stability of the routing system and detect problems.
Device(config-router)# eigrp log-neighbor-warnings 300

Configuring the EIGRP Event Logging Named Configuration


Device(config)# router eigrp AVERY
Device(config-router)# address-family ipv4 autonomous-system 45000
! Enables the logging of EIGRP neighbor warning messages.
Device(config-router-af)# eigrp log-neighbor-warnings 300
! Enables logging of EIGRP neighbor adjacency changes
Device(config-router-af)# eigrp log-neighbor-changes
Device(config-router-af)# topology base
! Sets the size of the EIGRP event log.
Device(config-router-af-topology)# eigrp event-log-size 10000

Configuring Equal and Unequal Cost Load Balancing Autonomous System Configuration


Device(config)# router eigrp 101
! Controls how traffic is distributed among routes when multiple routes for the same destination network have different costs.
Device(config-router)# traffic-share balanced
! Controls the maximum number of parallel routes that an IP routing protocol can support.
Device(config-router)# maximum-paths 5
! Controls load balancing in an internetwork based on EIGRP.
Device(config-router)# variance 1

Configuring Equal and Unequal Cost Load Balancing Named Configuration


Device(config)# router eigrp AVERY
Device(config-router)# address-family ipv4 autonomous-system 45000
Device(config-router-af)# topology base
! Controls how traffic is distributed among routes when multiple routes for the same destination network have different costs.
Device(config-router-af-topology)# traffic-share balanced
! Controls the maximum number of parallel routes that an IP routing protocol can support
Device(config-router-af-topology)# maximum-paths 5
! Controls load balancing in an internetwork based on EIGRP.
Device(config-router-af-topology)# variance 1

Adjusting the Interval Between Hello Packets and the Hold Time in an Autonomous System Configuration


Device(config)# router eigrp 101

Device(config)# interface GigabitEthernet 1/0
! Configures the hello interval for an EIGRP routing process.
! Command syntax: ip hello-interval eigrp as-number seconds 
Device(config-if)# ip hello-interval eigrp 101 10
! Configures the hold time for an EIGRP routing process.
! Command syntax: ip hold-time eigrp as-number seconds 
Device(config-if)# ip hold-time eigrp 101 40

Adjusting the Interval Between Hello Packets and the Hold Time in a Named Configuration


Device(config)# router eigrp AVERY
Device(config-router)# address-family ipv4 autonomous-system 45000
Device(config-router-af)# af-interface GigabitEthernet0/1
! Configures the hello interval for an EIGRP address family named configuration.
Device(config-router-af-interface)# hello-interval 10
! Configures the hold time for an EIGRP address family named configuration.
Device(config-router-af-interface)# hold-time 40

Disabling the Split Horizon Autonomous System Configuration


Device(config)# router eigrp 101

Device(config)# interface GigabitEthernet 1/0
! Disables split horizon.
Device(config-if)# no ip split-horizon eigrp 101

Disabling the Split Horizon and Next-Hop-Self Named Configuration


Device(config)# router eigrp AVERY
Device(config-router)# address-family ipv4 autonomous-system 45000
Device(config-router-af)# af-interface GigabitEthernet1/0
! Disables EIGRP split horizon.
Device(config-router-af-interface)# no split-horizon
! Instructs an EIGRP router to use the received next hop rather than the local outbound interface address as the next hop. The no-ecmp-mode keyword is an enhancement to the no next-hop-self command. When this optional keyword is enabled, all paths to a network in the EIGRP table are evaluated to check whether routes advertised from an interface were learned on the same interface.
Device(config-router-af-interface)# no next-hop-self no-ecmp-mode

Monitoring and Maintaining the EIGRP Autonomous System Configuration


! The show ip eigrp command displays prefix accounting information for EIGRP processes.
Device# show ip eigrp vrf VRF1 accounting

EIGRP-IPv4 Accounting for AS(100)/ID(10.0.2.1) VRF(VRF1)
Total Prefix Count: 4  States: A-Adjacency, P-Pending, D-Down
State Address/Source   Interface        Prefix   Restart  Restart/
                                        Count     Count   Reset(s)
 P    Redistributed     ----               0           3         211
 A    10.0.1.2          Gi0/0              2           0          84
 P    10.0.2.4          Se2/0              0           2         114
 D    10.0.1.3          Gi0/0              0           3           0


! The show ip eigrp events command displays the EIGRP event log.
Device# show ip eigrp events

1    02:37:58.171 NSF stale rt scan, peer: 10.0.0.0
2    02:37:58.167 Metric set: 10.0.0.1/24 284700416
3    02:37:58.167 FC sat rdbmet/succmet: 284700416 0
4    02:37:58.167 FC sat nh/ndbmet: 10.0.0.2 284700416
5    02:37:58.167 Find FS: 10.0.0.0/24 284700416
6    02:37:58.167 Rcv update met/succmet: 284956416 284700416
7    02:37:58.167 Rcv update dest/nh: 10.0.0.0/24 10.0.0.1
8    02:37:58.167 Peer nsf restarted: 10.0.0.1 Tunnel0
9    02:36:38.383 Metric set: 10.0.0.0/24 284700416
10   02:36:38.383 RDB delete: 10.0.0.0/24 10.0.0.1
11   02:36:38.383 FC sat rdbmet/succmet: 284700416 0
12   02:36:38.383 FC sat nh/ndbmet: 0.0.0.0 284700416


! Displays information about interfaces that are configured for EIGRP.
Device# show ip eigrp interfaces

EIGRP-IPv4 Interfaces for AS(60)
                    Xmit Queue    Mean   Pacing Time   Multicast   Pending
Interface   Peers   Un/Reliable   SRTT   Un/Reliable   Flow Timer  Routes
Gi0           0         0/0          0      11/434          0          0
Gi0           1         0/0        337       0/10           0          0
SE0:1.16      1         0/0         10       1/63         103          0
Tu0           1         0/0        330       0/16           0          0


! Displays neighbors discovered by EIGRP.
Device# show ip eigrp neighbors

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.1.1.2                 Gi0/0           13 00:00:03  1996   5000  0  5
2   10.1.1.9                 Gi0/0           14 00:02:24   206   5000  0  5
1   10.1.2.3                 Gi0/1           11 00:20:39  2202   5000  0  5


! Displays entries in the EIGRP topology table.
Device# show ip eigrp topology

EIGRP-IPv4 Topology Table for AS(1)/ID(10.0.0.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - Reply status, s - sia status
P 10.0.0.0/8, 1 successors, FD is 409600
        via 10.0.0.1 (409600/128256), GigabirEthernet0/0
P 172.16.1.0/24, 1 successors, FD is 409600
        via 10.0.0.1 (409600/128256), GigabitEthernet0/0
P 10.0.0.0/8, 1 successors, FD is 281600
        via Summary (281600/0), Null0
P 10.0.1.0/24, 1 successors, FD is 281600
        via Connected, GigabitEthernet0/0


! Displays the number of EIGRP packets sent and received.
Device# show ip eigrp traffic

EIGRP-IPv4 Traffic Statistics for AS(60)
Hellos sent/received: 21429/2809
Updates sent/received: 22/17
Queries sent/received: 0/0
Replies sent/received: 0/0
Acks sent/received: 16/13
SIA-Queries sent/received: 0/0
SIA-Replies sent/received: 0/0
Hello Process ID: 204
PDM Process ID: 203
Socket Queue: 0/2000/2/0 (current/max/highest/drops)
Input Queue: 0/2000/2/0 (current/max/highest/drops)


Example: Monitoring and Maintaining the EIGRP Named Configuration


! Displays prefix accounting information for EIGRP processes.
Device# show eigrp address-family ipv4 22 accounting

EIGRP-IPv4 VR(saf) Accounting for AS(22)/ID(10.0.0.1)
Total Prefix Count: 3  States: A-Adjacency, P-Pending, D-Down
State Address/Source    Interface       Prefix   Restart  Restart/
                                        Count     Count   Reset(s)
 A    10.0.0.2          Gi0/0               2         0        0
 P    10.0.2.4          Se2/0               0         2        114
 D    10.0.1.3          Gi0/0               0         3        0


! Displays information about EIGRP address-family events.
Device# show eigrp address-family ipv4 3 events

Event information for AS 3:
1 15:37:47.015 Change queue emptied, entries: 1
2 15:37:47.015 Metric set: 10.0.0.0/24 307200
3 15:37:47.015 Update reason, delay: new if 4294967295
4 15:37:47.015 Update sent, RD: 10.0.0.0/24 4294967295
5 15:37:47.015 Update reason, delay: metric chg 4294967295
6 15:37:47.015 Update sent, RD: 10.0.0.0/24 4294967295
7 15:37:47.015 Route installed: 10.0.0.0/24 10.0.1.2
8 15:37:47.015 Route installing: 10.0.0.0/24 10.0.1.2


! Displays information about interfaces that are configured for EIGRP.
Device# show eigrp address-family ipv4 4453 interfaces

EIGRP-IPv4 VR(Virtual-name) Address-family Neighbors for AS(4453)
Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface     Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Services
Se0           1          0/0        28      0/15          127           0
Se1           1          0/0        44      0/15          211           0


! Displays information about the neighbors that are discovered by EIGRP.
Device# show eigrp address-family ipv4 4453 neighbors

EIGRP-IPv4 VR(Virtual-name) Address-family Neighbors for AS(4453)
Address Interface Hold Uptime  SRTT  RTO    Q     Seq
                                     (sec)         (ms)  (ms)   Cnt   Num
172.16.81.28            GigabitEthernet1/1/1     13   0:00:41  0      11   4     20
172.16.80.28            GigabitEthernet0/0/1     14   0:02:01  0      10   12    24
172.16.80.31            GigabitEthernet0/1/1     12   0:02:02  0      4    5


! Displays information about EIGRP timers and expiration times.
Device# show eigrp address-family ipv4 4453 timers

EIGRP-IPv4 VR(Virtual-name) Address-family Timers for AS(4453)
Hello Process
Expiration Type
| 1.022 (parent)
| 1.022 Hello (Et0/0)
Update Process
Expiration Type
| 14.984 (parent)
| 14.984 (parent)
| 14.984 Peer holding
SIA Process
Expiration Type for Topo(base)
| 0.000 (parent)


! Displays entries in the EIGRP topology table.
Device# show eigrp address-family ipv4 4453 topology

EIGRP-IPv4 VR(Virtual-name) Topology Table for AS(4453)/ID(10.0.0.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - Reply status, s - sia Status
P  10.17.17.0/24, 1 successors, FD is 409600
          via 10.10.10.2 (409600/128256), GigabitEthernet3/0/1
P  172.16.19.0/24, 1 successors, FD is 409600
          via 10.10.10.2 (409600/128256), GigabitEthernet3/0/1
P  192.168.10.0/24, 1 successors, FD is 281600
          via Connected, GigabitEthernet3/0/1
P  10.10.10.0/24, 1 successors, FD is 281600
          via Redistributed (281600/0)


! Displays information about the number of EIGRP packets that are sent and received.
Device# show eigrp address-family ipv4 4453 traffic

EIGRP-IPv4 VR(virtual-name) Address-family Traffic Statistics for AS(4453)
  Hellos sent/received: 122/122
  Updates sent/received: 3/1
  Queries sent/received: 0/0
  Replies sent/received: 0/0
  Acks sent/received: 0/3
  SIA-Queries sent/received: 0/0
  SIA-Replies sent/received: 0/0
  Hello Process ID: 128
  PDM Process ID: 191
  Socket Queue: 0/2000/1/0 (current/max/highest/drops)
  Input Queue: 0/2000/1/0 (current/max/highest/drops


! Displays general information, including the versions of the EIGRP protocol features that are currently running on the device.
Device# show eigrp plugins

EIGRP feature plugins:::
    eigrp-release      :   5.00.00 : Portable EIGRP Release               
                       :  19.00.00 : Source Component Release(rel5)
    igrp2              :   3.00.00 : Reliable Transport/Dual Database     
    bfd                :   1.01.00 : BFD Platform Support                 
    mtr                :   1.00.01 : Multi-Topology Routing(MTR)           
    eigrp-pfr          :   1.00.01 : Performance Routing Support           
    ipv4-af            :   2.01.01 : Routing Protocol Support             
    ipv4-sf            :   1.01.00 : Service Distribution Support         
    external-client    :   1.02.00 : Service Distribution Client Support   
    ipv6-af            :   2.01.01 : Routing Protocol Support             
    ipv6-sf            :   1.01.00 : Service Distribution Support         
    snmp-agent         :   1.01.01 : SNMP/SNMPv2 Agent Support


! Displays general information about EIGRP protocols that are currently running on a device.
Device# show eigrp protocols

EIGRP-IPv4 Protocol for AS(10)
Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
NSF-aware route hold timer is 240
Router-ID: 10.0.1.1
Topology : 0 (base)
Active Timer: 3 min
Distance: internal 90 external 170
Maximum path: 4
Maximum hopcount 100
Maximum metric variance 1
EIGRP-IPv4 Protocol for AS(5) VRF(VRF1)
Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
NSF-aware route hold timer is 240
Router-ID: 10.1.2.1
Topology : 0 (base)
Active Timer: 3 min
Distance: internal 90 external 170
Maximum path: 4
Maximum hopcount 100
Maximum metric variance 1
Total Prefix Count: 0
Total Redist Count: 0

Comments